Установка и настройка модуля «Телефония»

1. Системные требования

Модуль «Простые звонки – Universe» встроен в программы:
— UNIVERSE-Красота (начиная с версии 1.6.10.0)
— UNIVERSE-Фитнес (начиная с версии 1.4.13.0)
— UNIVERSE-Медицина (начиная с версии 1.6.10.0)

Внимание! Для использования модуля «Простые звонки – Universe» нужно установить специальный ActiveX компонент «Простые звонки». Компонент ActiveX устанавливается на все компьютеры пользователей программ Universe, которые будут работать с «Простыми звонками».

Для установки и работы компонента ActiveX на компьютерах пользователей вам потребуется:
— Компьютер с операционной системой Windows 7, Windows 8, Windows 10, Windows 11, Windows Server 2003, Windows Server 2008, Windows Server 2008 R2, Windows Server 2012, Windows Server 2012 R2

2. Проверьте перед установкой

Перед установкой и настройкой компонента ActiveX на компьютеры пользователей, пожалуйста, убедитесь, что:

  • Компьютеры пользователей, на которые вы устанавливаете компонент ActiveX, удовлетворяют системным требованиям (см. «Системные требования »);
  • У вас есть доступ к компьютерам пользователей с правами администратора операционной системы;
  • У вас есть программа установки ProstieZvonki_ActiveX_2.0.exe компонента ActiveX.

3. Установка компонента ActiveX на компьютеры пользователей

3.1. Зайдите на компьютер пользователя Universe с правами администратора операционной системы.

3.2. Запустите программу установки компонента ActiveX ProstieZvonki_ActiveX_2.0.exe. Установите компонент ActiveX для всех пользователей Windows, следуя инструкциям.

3.3 Повторите установку компонента ActiveX на остальных компьютерах пользователей «Простых звонков».

4. Настройка подключения к серверу «Простые звонки»

Внимание! Если у вас нет доступа к описанным в данной инструкции настройкам, вам необходимо обратиться в компанию Universe Soft.

4.1. Войдите в Universe пользователем с правами администратора.

4.2. Откройте настройки оборудования:

Это изображение имеет пустой атрибут alt; его имя файла - 1.png

4.3. В открывшемся окне перейдите на вкладку Телефония:

Это изображение имеет пустой атрибут alt; его имя файла - 2.png

4.4. На открывшейся вкладке для всех трех номеров Телефон 1Телефон 2Телефон 3 задайте маску номера 0-(000)-000-00-00, как изображено на скриншоте:

Это изображение имеет пустой атрибут alt; его имя файла - 3.png

4.5. Найдите раздел Простые звонки:

Это изображение имеет пустой атрибут alt; его имя файла - 4.png

4.6. Отметьте галочку Включить.

4.7. Введите данные для подключения к Простым звонкам — Адрес сервера и Пароль в соответствующие поля. Получить их вы можете в письме с демо-версией или в личном кабинете вашего сервиса на странице Интеграция — CRM — UNIVERSE-Красота (аналогично для UNIVERSE-Медицина, UNIVERSE-Фитнес).

4.8. Укажите внутренний номер пользователя в поле Внутренний номер. Получить его вы можете после настройки интеграции с телефонией в личном кабинете Простых звонков, на странице Настройки — Пользователи, на странице нужного пользователя, в поле Внутренний номер для настройки CRM.

4.9. Повторите действия 4.1-4.8 для всех пользователей, которые будут работать с Простыми звонками.

5. Возможные проблемы и пути их решения

5.1. При входящих звонках не появляются уведомления, не получается сделать исходящий звонок

Причины
1. На компьютере не установлен компонент ActiveX 2. Настройки подключения заданы неправильно 3. У пользователя не указан внутренний номер телефона или указан внутренний номер, который отличается от внутреннего номера на телефоне пользователя

Решение
1. Установите компонент ActiveX на компьютер пользователя.
2. Проверьте, что вы корректно указали все необходимые параметры в настройках модуля (пункт 4.7 данной инструкции).
3.1. Задайте пользователю корректный внутренний номер телефона. После внесения изменений перезапустите Universe.
3.2. Проверьте, что пользователь может совершать/принимать звонки по своему внутреннему номеру без участия CRM (у него должна быть настроена программа софтфон или установлен аппаратный телефон).
3.3. После совершения звонка из CRM на софтфон или аппаратный телефон поступит входящий звонок, ответьте на него и после этого произойдет набор номера для исходящего звонка.

5.2. Интеграция работает нестабильно

Причины
1. У 2-х или более активных пользователей Universe указан одинаковый внутренний номер телефона.
2. На нескольких рабочих местах Universe открыта под одним и тем же пользователем.
3. На компьютере есть зависший сеанс пользователя Universe.

Решение
1. Внутренний номер телефона у каждого пользователя Universe должен быть уникальным.
2. Оставьте только один сеанс работы с Universe под определенным пользователем. Завершите все сеансы Universe, которые были открыты на других компьютерах под одним и тем же пользователем.
3. Завершите все зависшие сеансы Universe.